1998 Archive: Review of Codes to Create Polygon Meshes

NOTE: This page was written in 1998 and is kept for archive purposes only. For updated information about meshing, Contact ThermoAnalytics directly: sales@thermoanalytics.com

Introduction

There are many codes that will create a polygon mesh. Most of these will not create a mesh suitable for thermal analysis. The following is a review of some of these tools. We do not endorse any specific code; rather we supply this information as a guide to aid the MuSES/WinTherm user in selecting a tool appropriate for his specific application. This guide is based on our personal experience. We welcome input from users about their experiences with meshing codes; please send your comments to dml@thermoanalytics.com .

We group the codes that create polygon meshes into three broad categories:

  1. 3D Applications: Codes designed for visualization and animation. These codes may simply create the models, or they may also do the visualization and animation. Popular examples that perform both modeling and animation include Lightwave, FormZ Maya, and 3D Studio Max. 3D applications that concentrate on modeling include Rhino, Polytrans, Amapi, Nendo, and Scupltor ProTools.
  2. CAD/CAM: Codes designed to create blueprints and 3D models for design and manufacturing. Popular examples include Pro/E, AutoCad, Cadkey, DesignCad, IDEASMaster Series and TurboCad.
  3. Mesh Generators: Codes designed specifically to create meshes for scientific applications. Popular examples include Hypermesh, Gridgen, Mesh Modeler, Mentat, NASTRAN/PATRAN, Simail, SkyMesh, TetMesh, Truegrid, Turbomesh and VGRID.

For more information on the above listed programs see the reviews that follow. Also reviewed are support programs such as Wcvt2pov, to translate between common mesh file formats, and Decimator, to reduce the polygon count of a model.


In general, the 3D applications and the CAD/CAM programs will not produce meshes suitable for thermal or finite element analysis. Mesh generators, in general, are expensive and not easy to use.

Since MuSES is designed to be a low-cost tool for the PC, we will concentrate on low-cost PC meshing tools in our reviews.

Evaluation Using Sample Geometry

To evaluate the programs we devised the simple geometry illustrated below a rectangular rail, a curved pipe, and a hatch on a ship deck. We designed this geometry to examine how the meshing routines would handle:

  • An object that by nature is long and skinny (e.g., rail)
  • Embedding a circle into a rectangular mesh (e.g., pipe/deck interface)
  • Curved objects (e.g., curved pipe)
  • Cutting a "window" into a plate (e.g., hatch)
  • Automatic grouping of polygons into parts

The final part of the evaluation included examining the various file formats that the meshing program output. When appropriate, for programs that can process geometry from other sources, we also list input file formats.


3D Applications

Rhino

Manufacturer: McNeel and Associates
Web: http://www.rhino3d.com
Version tested: 1.0
Current version: 1.0
Platform/OS: Win95/NT Cost: $795. Special introductory price through end of 1998: $495.
Demo: Available free, downloadable from website. The demo is fully functional but it has a limit on the number of times that it can be used.

General: RHINO is a NURBS modeler intended for the industrial design and animation markets. RHINO supplies the user with nearly every conceivable option for creating geometry. 3D models, both simple and complicated, can be developed quickly and intuitively through its well-honed interface. The user operates within four windows: three windows show the model from the three cardinal directions while the fourth screen is a perspective view. Any of these views can be shaded. Once the NURBS geometry is created, an automated meshing algorithm creates a mesh that comes reasonably close to being suitable for MuSES. Rhino permits the import of NURBS surfaces created by CAD programs using the IGES file format.

Principal Caveats: The main caveat is the multiplicity of the commands all of which do something a bit different, and sometimes do not act as expected. For example, there are two methods to create a rectangular deck: "Rectangle" and "Surface from 3 or 4 Corner Points." A rectangle is not a surface and hence cannot be meshed unless it is extruded into a solid. The "Surface from 3 or 4 Corner Points" can be. Adjacent parts (e.g., the pipe, rail, and deck) will not share common vertices unless the parts are combined as one. Geometric parts can be combined via the Solid->(Boolean) Union/Difference or by the Edit->Join command. The Solid->Union/Difference commands work on both solids and surfaces. Once you create the mesh, you can break the mesh back into its constituent parts and sometimes into subparts—via the Tools->Polygon Mesh->Explode command. The Solid->Union/Difference commands often do not do what you might expect; you have to try them to see what the result is. Fortunately, there is an Edit->Undo command.

Performance in Creating the Sample Geometry: Creating the sample geometry in RHINO was straight-forward and fast. To create the deck we either an extruded a rectangle (shown above) or better created a Surface from 4 Corner Points (shown below). To create the hatch, we created a solid rectangular box, moved it so that it protruded on both sides of the deck, split the box from the deck, and then deleted the box and the square that the split command created in the deck. We punched in Ortho (at bottom of screen) to keep us purely vertical when we translated the box. The Edit->Split command is more robust than the Edit->Trim command, but the user then must then delete the trimmed part (trim automatically deletes the part). To create the curved pipe, we chose a circle and an arc, and then used the Surface->Sweep Along 1 Rail command to sweep the circle along the arc.

RHINO automatically created separate parts for each object created. As can be seen in the figure above, adjacent parts in the resulting mesh do not share common vertices. In order to generate a mesh with the pipe and rail correctly embedded into the deck, we had to merge the parts together. To combine the pipe with the deck, the Solid->Intersect command worked, whereas for the box and deck, the Solid->Difference command produced the desired result. We created the mesh (Tools->Polygon Mesh->From NURBS Object) using the Detailed Controls. We set the Max Aspect Ratio = 1 and adjusted the Min Edge Length to control the number of polygons in the mesh. After meshing we used the Tools->Polygon Mesh->Explode command. This action exploded the box into its five sides that we then merged into a single part using Tools->Polygon Mesh->Join. Finally, we multiple-selected the three parts of the mesh and produced an OBJ file using the File-Export Selected command.

All inputs can either be entered numerically using the keyboard for exact positioning and dimensioning, or by graphically using the mouse. The meshing can be controlled simply by a number-of-facets slider or by a more detailed control panel. Meshes can be quickly reviewed and adjusted before the meshing parameters are finalized. One useful feature is the Analyze->Edge Tools commands that can verify whether or not objects have been embedded into one another (e.g., check to see whether within the deck there are edges for the base of the rail box and the pipe). The Analyze->Direction command displays surface normals.

Input Surface File Formats: IGES

Output File Formats: RHINO can output a mesh in 5 formats: 3DS, DXF, RAW triangles, Lightwave LWO and Wavefront OBJ. The DXF export (according to WC2POV27) contained the entire geometry as a single part; all other file exports contained parts if there were any. One caution about viewing the 3DS file format: when imported into WC2POV27 the geometry was painted white rendering it invisible against the default white background.

Lightwave

Manufacturer: Newtek
Web: http://www.newtek.com
Version tested: 5.0
Current Version: 5.6 Platform/OS: Win95/NT/Sun Solaris/Mac
Cost: Street price ranges from $1200 to $1900 depending on version. A reduced capability version (the modeler is apparently little affected; most of the reduced capability is in the animation half of the package) called Inspire 3D sells for less than $400.

General: LIGHTWAVE is a polygon modeler and animation package. Its main use is to create special effects and animation for TV and film. The modeling tools tend to be basic but useful. The user operates in a four-window screen: three windows show the model from the three cardinal directions while the fourth screen is a perspective view which can be shaded. Since it is a polygon modeler, it can be completely controlled by the user, in how polygonal objects are created (e.g., the resolution of facets in the curved pipe). Unfortunately, the parts of the mesh that are not under the user control (e.g., how the hatch, pipe, and rail are embedded into the deck) result in meshes that are not suitable for thermal analysis due to the proliferation of high aspect polygons.

Principal Caveats: The polygon mesh that Lightwave creates will often contain high aspect polygons and/or fans of triangles. Depending on the file format, polygons may be multisided (i.e., in the sample geometry, the deck in the OBJ file contained 34 sides). LIGHTWAVE lacks some basic functions such as a means of creating a circular arc (a problem presumably addressed by a plug-in or upgrade). The user must manually select polygons and group them into parts.

Performance in Creating the Sample Geometry: Embedding the hatch, rail and pipe into the deck mesh involved two steps. First, we subtracted the 2D outlines of the objects from the deck (to embed the meshes) and created solids in order to create the actual holes in the deck. All inputs can either be entered numerically using the keyboard for exact positioning and dimensioning, or by graphically using the mouse. The meshing of created objects (e.g., curved pipe) is under direct user control while the embedding of the meshing is outside the user control (and apparently occurs during file export).

Output File Formats: LIGHTWAVE can output a mesh in four formats: 3DS, DXF, Lightwave LWO, and Wavefront OBJ. The Wavefront OBJ mesh, when viewed in WC2POV27, appeared askew (i.e., the 34-sided deck polygon appeared collapsed into a single corner). INSPIRE 3D will also export meshes in VRML and VRML 2 formats.

Polytrans

Manufacturer: Okino
Web: http://www.okino.com
Version tested: 2.1n (demo version)
Current Version: 2.2
Platform/OS: Win95/NT/SGI
Cost: Win95/NT $395, SGI $495
+ $195 Win95/NT for ACIS SAT module (not available for SGI)
+ $195 Win95/NT or $245 SGI for IGES 5.3 NURBS module
Note on cost: Okino also sells NuGraf (for Win95/NT only) which contains all the capabilities of Polytrans while adding in rendering. NuGraf sells for $495

General: Polytrans translates 3D geometry models, both in polygon mesh and NURBS formats. Polytrans reads in and converts the entire file contents so that textures, normals, animation, camera and light info, and comments are all fully translated. Objects (NURB surfaces or polygons) can be deleted or assigned to different parts. Simple 3D objects can be created and added. Objects from multiple files can be added together. Polytrans can polygonize or triangulate NURBS objects. When exporting polygon meshes to Wavefront OBJ format, the user can direct Polytrans to triangulate concave polygons and/or to triangulate any polygon with more than 4 sides.

Principal Caveats: The user has no control over the resolution of the meshing of NURBS objects (i.e., no control over the number of polygons created). While meshing, Polytrans will create a fan of triangles and long skinny facets.

Performance in Creating the Sample Geometry: We exported the geometry created inside Rhino as a Wavefront OBJ NURBS file, and read that file into Polytrans. Since we used a demo version of Polytrans in this trial, every fifth polygon is missing in the exported geometry since this is how Okino disables the full-up version for demo purposes. Another limitation is that only polygon meshes can be exported (e.g., no NURBS export capability in the demo version).

The mesh is watertight; adjacent parts shared common vertices. The user had no control over the resolution of the mesh; consequently the circular pipe had more polygons than what was desired. The mesh, however, does accurately model the pipe. When given a long skinny object such as the rail, Polytrans created long and skinny polygons. Although the rail and pipe were successfully embedded in the deck, the resulting deck mesh does not exhibit uniformly spaced polygons and contains several fans of long and skinny facets.

Input File Formats: Polytrans imports Alias triangle (tri), ACIS SAT (with optional module), Apple 3D metafile (3dm), 3D Studio (3DS), 3D Studio Max (3D Studio MAX must be installed on computer for this module to function), CAD 3D (3d2), Detailer (vdu), DXF, IGES 5.3 (with optional module), Imagine (ima), Lightwave (lw), NuGraf (bdf), Openflight (with optional module), Pro/E (slp), Softimage (hrc), StereoLithography (stl), Strata StudioPro (vis), Truespace (cob & scn), USGS DEM, Vista Pro (dem), and Wavefront (obj) (NURBS and polygons).

Output File Formats: Polytrans exports Alias triangle, Apple 3D Metafile, 3DS, Detailer, DirectX (x), DXF, IGES 5.x, Imagine, Lightscape, Lightwave, NuGraf, Open GL C code, OpenFlight, POV Ray, Pro/E, Renderman (rib) (NURBS and meshes), Renderware (rwx), SoftImage, StereoLithography, Strat StudioPro, TrueSpace, Wavefront, and VRML (wrl).


Short Reviews

AMAPI

Manufacturer: TGS (Template Graphics Solution)
Web: http://www.tgs.com
Version tested: 3.0
Current Version: 4.0
Platform/OS: Win95/NT/SGI/LINUX/MAC
Cost: $249

General: Amapi is a polygon and NURBS modeler with extensive file import (9 formats) and export (22 formats) capability.

Principal Caveats: The user interface is unorthodox; the interface is best explained by viewing it (visit the TGS website). Parts are not embedded in the meshes of other parts (e.g., adjacent parts do not share common vertices). The coffeepot example in their manual (download AS20man.PDF from their web site; example is on pages 2-7 which is listed as page 36 by the Acrobat viewer) clearly shows that the individual parts composing the coffeepot do not share common vertices. Mesh subdivision can destroy the water tightness of a mesh. (See the sphere example in the manual, pages 1-9 which is listed as page 14 by the Acrobat viewer.)

Performance in Creating Geometries: NURBS objects are overlaid with a rectangular mesh of quad polygons, apparently under complete user control (per number of polygons). Polygon meshes and NURBS objects can be subdivided and smoothed.

Output File Formats: Amapi imports DXF, 3DMF (on Macintosh only), VRML, and IGES. Amapi exports DXF, IGES, STL, RIB, Ray Dream Designer, 3DS, 3DMF (on Macintosh only), PovRay, Strata Studio Pro (on Macintosh only), VRML, TrueSpace, Lightwave and others.

Formz

Manufacturer: auto-des-sys
Web: http://www.formz.com
Version tested: 2.9
Current version: 3.0
Platform/OS: Win95/NT/MAC
Cost: $1495 retail

General: FORMZ is a very capable polygon and metaball surface modeler. A perusal of its Quick Reference Manual (downloadable from their web site as quickref.pdf) shows the comprehensive features in FORMZ.

Principal Caveats: Many wireframe models are illustrated in the FORMZ Demo Mini User's Manual (downloadable as 2_9_FZ_MM_Reader.pdf from their website). None of the wireframes shown are watertight; adjacent parts do not share common vertices.

Performance in Creating Geometries: FORMZ file export commands have many options. For most export formats the user can direct FORMZ to subdivide any concave polygons and to include surface normal data. During STL export FORMZ can check for minimum triangle size or for intersecting triangles. When importing polygon meshes FORMZ can create 3D solids from the meshes. FORMZ has a triangulate command with two sets of options. The first set of options determines if all or if only non-planar faces are triangulated. The second set determines if the triangles created should be distributed either in fans or uniformly across each face (look at section M.27 in the Quick Reference to see the two options for uniform distribution meshing).

Input File Formats: FORMZ can import DXF, IGES (3D curves, lines and trimmed surfaces), OBJ, STL, 3DMF, VRML and others.

Output File Formats: FORMZ can export DXF, IGES (3D curves, lines and trimmed surfaces), OBJ, STL, 3DMF, VRML and others.


Additional information about 3D Applications

Maya

Manufacturer: Alias/Wavefront
Web: http://www.aw.sgi.com
Current version: 1.0
Platform/OS: SGI
Cost: $7500+ ($50K typical full-up configuration)

General: 3D software application for character animation and visual effects. Contains impressive array of NURBS and polygon modeling tools.

Nendo

Manufacturer: Nichimen
Web: http://www.michimen.com
Current version:
Platform/OS: Win95/NT
Cost: $99

General: 3D modeling and paint application. Inputs and exports 3DS, OBJ, and VRML 2.0. The manual states that objects will be triangulated for 3DS export. No numeric controls; all dimensioning done graphically via mouse. A demo version is available for free download; the demo does not allow import/export operations.

Sculptor ProTools

Manufacturer: 4D Vision
Web: http://www.4dvision.com
Current version: 3.0
Platform/OS: Win95/NT
Cost: $169

General: Nurbs modelerl. Imports and exports 3DS, OBJ and DXF. Also exports STL, POV, IGES and RAW. A demo is available for free download; the demo does not permit any file open or save operations. Although designed for organic modeling, ProTools does support numeric input for object dimensioning.

3D Studio MAX

Manufacturer: Discreet Logic
Web: http://www.ktx.com
Current version: R 2.
Platform/OS: Win95/NT
Cost: $3495 retail

General: Interactive and object-oriented 3D modeling and animation application with intensive plug-in support. A demo CD is available. Built-in file format support for 3DS and DXF R14.


CAD/CAM

PRO-E

Manufacturer: Parametric Technology Corporation
Web: http://www.ptc.com
Version tested: 18
Current version: 20
Platform/OS: Unix (Pro/DESKTOP for Win96/98/NT)
Cost: tens of thousands of dollars for Pro/E, $3495 for Pro/DESKTOP

General: Pro/ENGINEER (Pro/E) is a family of integrated parametric CAD/CAM applications. Pro/E creates solid models and provides a triangulate command to polygonize solid objects. Parametric Technology Corporation also sells a Pro/MESH utility to create finite element (FEA) meshes.

Principal Caveats: When using the triangulate command the user has no control over the triangulation and Pro/E will create many long and skinny triangles. The Pro/MESH option provides the user with more control while generating a true finite element mesh.

Performance in Creating the Sample Geometry: Pro/E preserves part info (grouping of polygons) when either the triangulate command or Pro/MESH option is used. Pro/MESH provides automatic finite element mesh generation of solid models and thin-walled solids created in Pro/E.

Output File Formats: PRO/E, with or without the PRO/MESH option, will export polygon meshes in Inventor, PRO/E slp, Wavefront obj, StereoLithography, DXF, VRML, and other file formats.

Windows Version: In October 1998 PTC announced Pro/DESKTOP, a 2D/3D CAD pacakge for Win95/98/NT. File format support includes VRML, DXF, IGES and STL.


Additional Information about CAD/CAM

AutoCAD

Manufacturer: Autodesk
Web: http://www.autodesk.com
Current version: 14.01
Platform/OS: Win95/NT
Cost: $3750 retail

General: 2D/3D CAD program. Export in DXF and STL. Free demo CD available. AutoCAD R14 can triangulate a solid object using the stlout command and export the resulting polygonal mesh as a STL file. The stlout command has two restrictions: · The object must reside completely within the positive x-y-z octant. · Only one object can be triangulated and exported at a time. There are other techniques for creating a mesh inside AutoCAD; none seem to produce a mesh suitable for thermal analysis. In general, the resolution of the mesh can be adjusted through the system variable facetres. Although the triangulation produces a reasonable thermal mesh on some objects such as spheres and toroids, on cylinders and cones AutoCAD will usually produce long and skinny triangles. For a cylinder, for example, AutoCAD will create a series of triangles stretching from the top to the bottom. Increasing the facetres variable increases the number of long and skinny triangles fit around the cylinder, and actually makes the problem worse by increasing the aspect ratio of the triangles.

At left is an example mesh from AutoCAD. Long and skinny triangles abound. The long and skinny triangles on the top of the box are arranged in fans. The large difference in the size of polygons on the box top may affect the results of the thermal analysis.

CADKEY

Manufacturer: Baystate Technologies
Web: http://www.baystate.com
Current version: CADKEY 98
Platform/OS: Win95/Win98/NT
Cost: $1995 retail

General: 2D/3D CAD program with ACIS solid modeling. File formats include STEP AP203, DXF 14.01, and STL.

DesignCAD

Manufacturer: Viagrafix
Web: http://www.designcad.com
Current version: Pro 2000
Platform/OS: Win95/Win98/NT
Cost: $600 retail/$300 competitive upgrade

General: 2D/3D CAD program. File formats include DXF and VRML.

IDEAS Master Series

Manufacturer: Structural Dynamics Research Corporation
Web: http://www.cc-technologies.qc.ca/ideas.htm
Current version: 6
Platform/OS: Unix (Artisan series for NT)
Cost: Unkown

General: 2D/3D CAD program with extensions for meshing, simulation, drafting. The meshing option appears within the simulation application. The mesh can be exported in 25 different file formats including IGES, Nastran, Open Inventor, STEP AP203, VDA, and VRML. Artisan supports IGES, VDA amd DXF formats.

TurboCAD

Manufacturer: IMSI
Web: http://www.turbocad.com
Current version: 5 for TurboCAD, 2 for 3D Modeler
Platform/OS: Win95/NT Cost: V5 Standard $130 V5 Pro $295 3D Modeler $100 Solid Modeler $1995

General: Family of 2D/3D CAD applications. TurboCAD Standard supports DXF and 3DS file formats. A 15 day trial version of TurboCAD Basic is downloadable from the web; the basic does not support 3DS or VRML file export. TurboCAD Pro supports DRML, DXF R13, 3DS, VRML and IGES. The 3D Modeler and Solid Modeler are based on the ACIS kernel. The 3D Modeler supports DXF R13 and VRML. The Solid Modeler supports IGES, DXF, STL, and VRML.

Mesh Generators

Albert Hines posted an online review of mesh generators for heat transfer and fluid flow. He reviewed Patran, Meshcast, Hypermesh and Algor. Copies of his review, which is entitled Comparison of Finite Element Meshing Software, exist at various places on the web including http://www.andrew.cmu.edu/user/sowen/software/.

More information about both public domain and commercial finite element meshing programs can be found at http://userpage.fu-berlin.de/~wwwgravi/gravi_ag/mitarbeiter/chrisK/austi... and http://www-users.informatik.rwth-aachen.de/~roberts/software.html and http://www.engr.usask.ca/~macphed/finite/fe_resources/mesh.html .

HyperMesh

Manufacturer: Altair Computing
Web: http://www.altair.com
Version tested: 2.1
Current version: 3.0
Platform/OS: Win95/NT, HP, SUN, SGI, IBM, DEC Alpha
Cost: few thousands of dollars

General: Hypermesh can pre- and post-process finite element meshes.

Principal Caveats: Users (such as Albert Hines—see review at top of Mesher's category—and others) claim that Hypermesh can be cumbersome to use, especially when dealing with a non-simple geometry.

Performance: Hypermesh can deal with both shell and solid models. For meshing of surfaces Hypermesh has many options and capabilities including meshing across multiple surface boundaries and choosing between quad or triangle-dominated meshes. Model editing features include combining, detaching, and translating elements. Hypermesh can check meshes for duplicate elements, facet warpage, aspect ratio, skewness, and can display and modify element normals.

Upgrades to Version 3: The new geometry cleanup tool allows users to correct geometry incompatibilities and create larger meshable areas for automeshing. Among the surface cleanup tasks are the removal of unwanted small holes, closing of gaps, removal of overlaps, and alignment or recognition of adjacent surface edges and vertices. HyperMesh 3.0 supports direct computer-aided design (CAD) data access for CATIA model files and Unigraphics (UG) prt files. The enhanced surface automeshing takes advantage of this by allowing the user to interactively mesh across multiple surfaces.

Input File Formats: FEA formats (ABAQUS, ANSYS, NASTRAN, I-DEAS, PATRAN, and others). 3D geometry formats (ACIS SAT, DXF, IGES, STL, VDAFS, and others).

Output File Formats: ABAQUS, ANSYS, NASTRAN, I-DEAS, PATRAN, STL, and others.


Additional information about Mesh Generators

The following information about mesh generators was copied from the internet. The URL address of the source of the information is given for each code description.

Gridgen version 13

Pointwise Inc http://www.pointwise.com

Gridgen's triangular surface mesher saves engineers time by meshing across one or more trimmed NURB surfaces, even when there are gaps and overlaps between the surfaces. This allows an engineer to begin meshing a CAD geometry without having to spend time cleaning up dirty geometry. Version 13 adds new diagnostic capabilities that lets users graphically examine several grid quality measures in order to assess the suitability of grids and identify any problem areas.

Gridgen is known for its:

  • Interactive interface using OpenGL graphics to run on Unix workstations from Silicon Graphics, Hewlett Packard, IBM, Digital, Sun, and Win95/98/NT
  • Geometry modeling tools
  • Robust IGES import
  • Fault-tolerant gridding methods that let analysts work effectively with large and less than-perfect models
  • Highly automated and wide variety of gridding methods that allow users to create good grids right from the start
  • Filters to export grid and boundary condition data formatted for use with a wide variety of analysis software including FIELDVIEW, NASTRAN, PATRAN, UCD, VRML, STL, ADPAC, CFX-4, COBALT, FDNS, FLUENT, FLUENT/UNS, GASP, GUST, INCA, NPARC, OVERFLOW, PHOENICS, RAMPANT, SCRYU, STAR-CD, TASCflow, TEAM, VSAERO, and WIND

Mesh Modeler

Army High Performance Computing Research Center (AHPCRC)
http://www.arc.umn.edu/gvl-software/ -> Mesh Modeler

The mesh modeler is a (Non-Uniform Rational B-Spline) 3D surface modeler geared toward model creation for automatic meshing software. It uses edge-based parametric surface patches to help ensure that the geometric requirements of automatic meshing algorithms are met. Eventually AHPCRC surface and 3D meshing codes will be added to the GUI to provide integrated modeling and meshing. Mesh modeler is currently in development stage.

Mentat Mesh Generator

MARC
http://www.marc.com/Products/meshgen.html

Mentat contains many powerful methods to generate a finite element mesh. These procedures can all be used so that you can easily construct complex finite element meshes. Interactively, using a few key strokes and mouse picks, a finite element mesh can be created. There are two basic techniques: the first is to create the mesh directly, while the second is to create the geometry and then use one of the automatic meshers on this geometry. In either case, the mesh can be modified by commands that include copying, expanding the dimension, subdividing, smoothing, and refining. The validity of the finite element model can be verified using either graphical techniques or by checking the distortions.

Geometries can also be constructed or imported from CAD systems. All geometry is treated consistently as NURBS. Geometric surfaces can be created using quadrilateral patches, ruled surfaces, arbitrarily dragged curves, Bezier, NURBS, cylinders, or spheres.

These geometric surfaces can be converted to a finite element mesh using either:

  • mapping techniques -- a regular mesh is mapped onto the geometric surface
  • overlay mesher -- a regular quadrilateral mesh is mapped onto the geometric surface and then trimmed to the boundary
  • fully automatic mesh generators -- a triangular or quadrilateral mesh is created on the surface

The fully automatic mesh generators allow you to specify the number of points along the boundary, the element length ratios, and the quality of the mesh. Full associativity is preserved between the surface geometry and the finite element mesh. Coordinate changes to the geometry are automatically reflected in the mesh. Boundary conditions applied to the geometry are transferred to the elements.

NASTRAN/PATRAN

MacNeal Schwindler Corp.
http://www.macsh.com

NASTRAN and PATRAN are high-end modeling and analysis tools. Current versions and platforms include PATRAN 8.0 (UNIX/NT), NASTRAN 70.5 (UNIX), and NASTRAN for Windows 3.0 (Win95/NT). All feature a GUI-based mesh modeling capability. All versions can handle IGES files. NASTRAN for Windows can also handle DXF and STL files. Advanced versions can be linked directly to high-end CAD systems.

The meshing capability of these programs is quite extensive. A listing of meshing features can be found on their PATRAN web page in the "MSC/Patran Pre- and Post-Processing" data sheet.

Simail version 6.1-4

Simulog (France) http://www.simulog.fr/US/html/prods/simail.html

Simail is an interactive graphical mesh generator generating linear, surface or volumetric meshes. Powerful algorithms, open architecture and user-friendly interface lead to increased productivity in complex mesh engineering.

Mesh generation capabilities include:

  • Structured or unstructured meshes.
  • Numerous generation methods: block splitting, algebraic, extrusion, advancing-front, Voronoï-Delaunay, etc.
  • Tetmesh automatic tetrahedral mesh generator.
  • Automatic mesh generation of surfaces described through NURBS or BEZIER
  • Accepts common file formats (IGES, SET,...) or native CAD files
  • Mesh quality checking to comply with specific solver requirements.

Platforms supported include:

  • Digital Alpha, OSF/1 3.2x or 4.0x Operating System
  • HP 9000 series 700, HP-UX 9.0x to 10.20 Operating System
  • IBM RS6000, AIX 3.2.5 or 4.1.5 Operating System
  • SGI, IRIX 5.3 to 6.4 Operating Systems
  • Sun, Sun OS 4.1.3 or 4.1.4 Operating System
  • Sun, Solaris 2.3 to 2.5.1 Operating System

Sky/Mesh 2

Skyblue Systems Inc
http://www.skybluesystems.com/mesh2.htm

SKY/Mesh2 is a fully automatic finite element mesh generator that creates surface meshes in 3D space. The SKY/Mesh2 meshing process can be invoked as an interactive program, or through custom batch meshing programs for specific applications. The mesh is attached to an underlying parametric geometry so that the grid can be quickly changed by altering parameters (dimensions) of the model. These geometries can be multiple regions in a flat 2D plane or multiple curvilinear surfaces in 3D space. Mesh density is automatically calculated to track geometric features of varying sizes, with the ability to add extra control to refine the mesh overall or in selected locations.

2D meshes support a full range of element shapes of first- through third-order. 3D meshes can be created using the method of extrusion, where 3D models are created by adding or subtracting materials layer by layer from a 2D model. The numbers of nodes and elements are limited only by the memory available on the computer, not arbitrary pre-programmed limits.

A mesh smoothing algorithm can be invoked that serves the dual purpose of optimizing element aspect ratios and snapping the boundary nodes back to the underlying geometry when the user changes the geometric parameters.

All Skyblue software is supported on Windows 95, Windows NT, and Unix (Sun, HP) platforms.

Skyblue offers a demo version of Sky/Mesh2 that can be downloaded from their web site.

TETMESH

Computational Mechanics Co. Inc. (COMCO)/WPAFB http://www.comco.com/main/research/Store.html

TETMESH software packages, developed under Air Force funding (Flight Dynamics Directorate, Wright-Patterson AFB), have reached a beta-release stage. TETMESH capabilities include:

  • Input geometry definition in standard formats:
  • IGES trimmed surface format
  • TETMESH E3S trimmed surface format
  • Network (or 'panel-code') format (converted to E3S)
  • Surface triangulation in both parameter and physical space
  • Delaunay tetrahedralization of domain interior (with boundary face enforcement)
  • Boundary condition definition by input surfaces
  • Zero-thickness surfaces
  • Internal boundaries
  • Motif-based interactive GUI
  • Grid visualization (with hardware graphics support)

The Air Force owns rights to the software.

Truegrid

XYZ Scientific Applications Inc
http://www.truegrid.com/

TrueGrid® is a computer program used to tessellate a geometric model into hexahedron brick elements and quadrilateral shell elements. TrueGrid®'s projection method (based on projective geometry) eliminates the need for the user to specify the bulk of the details other less intelligent mesh generators require. This precise projection method can deal with complex geometries. Surfaces and curves can have unrestricted curvature. The user points to the surfaces and curves and TrueGrid® does the rest. Nodes are automatically distributed on surfaces and curves with boundary nodes automatically placed at the intersections of the surfaces. The distribution of nodes is controlled by sophisticated interpolation and smoothing methods.

Modern designs can be accomplished using a Computer Aided Design system (CAD) or a Solids Modeler. TrueGrid® uses the standard IGES interface to most CAD systems to import the geometry and transform the design into a numerical model needed by a simulation code. TrueGrid® also has many types of surfaces and curves using geometric forms, functions, and arbitrary data. In addition, boundary and initial conditions, constraints, and loads are assigned to the model. The TrueGrid® user can then select to format the model data for most of the popular three-dimensional simulation codes.

 

Exports to Finite Element Simulation Codes include ABAQUS, ALE3D, ANSYS, AUTODYNTM, DYNA3D, LS-DYNA3D, LS-NIKE, MARC, NASTRAN, PATRAN Neutral File, and TOPAZ3D. Exports to Computational Fluid Dynamics (CFD) Simulation Codes include CFD-ACE, CFX , COMPACT, FIDAP, FLUENTTM, GRIDGEN3D, NEKTON, PLOT3D, REFLEQS, STAR-CD, and TASCflowTM.

Platform and systems supported include:

  • SGI IRIX 5.3 and IRIX 6.2
  • SUN SunOS 4 and SOLARIS 2
  • HP 9000/700 HP-UX 9.0.1
  • IBM RS6000 AIX 4.1.1
  • IBM Power PC AIX 4.1.1
  • DEC ALPHA DEC UNIX 2
  • Pentium Pro NT 3.51, NT 4.0, and Windows 95
  • PC 386/486 DOS 4.0

A TrueGrid® DEMO for WINDOWS 95/NT is available from their web site.

TurboMesh

General Mechanics
http://www.turbomesh.com/

TurboMeshTM is a powerful, easy to use, cost-effective finite element mesh generator that runs on all Silicon Graphics workstations. TurboMesh allows interactive, real-time, 3D mesh generation. 3D CAD models can be imported via IGES or built altogether from scratch within TurboMesh.

Input: IGES and I-DEAS universal files Output: I-DEAS universal, MSC/Nastran, Ansys, Cosmos/M, PostScript 3D Geometry: Points, Lines, Circular arcs and circles, Bezier curves, Nurbs curves, Surface-intersection curves Finite element entities: Nodes, Beam elements , 3- and 4-noded shell elements, Solid elements (tetrahedra, wedges and hexahedra), Geometric property tables, Material property tables (reusable)

As advertised on the web site, the special introductory cost is $1990 ($5990 otherwise).

Turbomesh

SolidPoint

TurboMesh is powerful and versatile engineering and manufacturing software. By employing a novel, highly efficient meshing algorithm, Turbomesh provides the computing horsepower to allow designers and manufacturers to develop their designs on a desktop PC. In addition, TurboMesh allows the engineer to directly relate product design to manufacturing by facilitating the simulation and visualization of the design in 3D space. This gives the designer the ability to see a highly accurate model, or rendering, of the product as the design is edited and refined. With this powerful software; analysis, design, and production are linked with a powerful, multiple-view database allowing the designer unprecedented flexibility and accuracy on a low-cost, desktop platform.

SolidPoint offers a functional demo of their Finite Element Analysis Surface Meshing Package (Turbomesh) on their website. This software runs under Windows 95 or NT.

VGRID version 2.7

ViGYAN Inc/NASA Langley
http://www.vigyan.com/vigyan/vgrid.html

VGRID is a robust, user-friendly computer program for the generation of three dimensional unstructured (triangular surface and tetrahedral volume) grids in geometrically complex domains. The base code (VGRID3D) has been developed by ViGYAN, Inc. under a NASA Small Business Innovation Research (SBIR) contract. Since completion of that project (1990), considerable extensions to VGRID have been developed at NASA Langley Research Center. Along with a graphical user interface utility GridTool and a grid post-processing program POSTGRID, the VGRID system provides a reliable tool for the fast and convenient generation of unstructured grids around complex configurations.

VGRID is based on the Advancing-Front Method (AFM) for the generation of tetrahedral `Euler' grids. The present version of the code incorporates the following salient features:

  • Dynamic memory allocation.
  • Patch `T-connections' for convenient patching of surface definitions.
  • Interactive rearrangement of surface patches for obtaining high quality surface triangulations.
  • Surface mesh quality check.
  • Interactive generation of both surface and volume grids using Silicon Graphics, Inc. workstations through the mouse-driven graphical and animation capabilities of the codes.
  • Graphical display of grid distribution in the field on moving planes prior to generation of the actual volume grid.
  • Restart capability with an efficient `recurrent' renumbering system allowing the generation of large grids on small workstations.
  • Grid post-processing with POSTGRID for local remeshing of any void/anomaly in a grid, volume grid quality check, and automatic grid quality enhancement with local remeshing.
  • Fast and convenient generation of grids around complex configurations on SGI workstations.

Usable by non-experts.

VGRID executables are available to the U.S. users free of charge. The technology is disseminated by the NASA Langley Research Center. ViGYAN, Inc. provides technical support, training, and customization of the codes for a fee. The NASA Langley contact is:
Dr. Shahyar Pirzadeh
Mail Stop 499
NASA Langley Research Center
Hampton, VA 23681
Phone: (757) 864-2245
FAX: (757) 864-8469
email: s.pirzadeh@larc.nasa.gov


Other Tools

WCVT2POV

Manufacturer: Keith Rule
Web: http://www.europa.com/~keithr
Version tested: 2.7
Platform/OS: Win95/NT and Win3.1 (Version 2.6)
Cost: Freeware.

General: WCVT2POV is a freeware application to convert polygon meshes. It imports 3DS, Wavefront OBJ, RAW, DXF and others. It exports DXF, ascii 3DS, POV, RAW, Truespace COB, VRML 1.0, Wavefront OBJ, and others. An updated version, called Crossroads, which has more capability is also available as freeware. Do not use Crossroads if you wish to export a Wavefront OBJ file because there is a serious bug in the export function.

Polytrans

Polytrans is designed to convert between different mesh formats. For a review of Polytrans see the 3D Applications section.

Decimator

Manufacturer: Geomagic
Web: http://www.geomagic.com
Version tested: 1.0.2 (demo version)
Platform/OS: Win95/98/NT and SGI Cost: $295

General: Decimator is a polygon reduction tool designed to reduce the number of triangles in a polygon mesh. The application can import and export meshes in STL, OBJ, VRML 1.0, DXF R14 and 3DS formats. Inventor and IGES mesh files can be exported. We tested the Decimator demo on a mesh of an automobile. Below are before and after pictures of the mesh. Please note that the demo omits random polygons during file export; otherwise, the demo is a fully functional program. While Decimator successfully preserved the shape of the model even after a 50% reduction in the polygon count, the process created fans of triangles (e.g., wheels) and long skinny triangles (e.g., car door).


Learn More about Meshing

1998 Archive: Review of Codes to Create Polygon Meshes

There are many codes that will create a polygon mesh. Most of these will not create a mesh suitable for thermal analysis. The following is a review of some of these tools. We do not endorse any specific code; rather, we supply this information as a guide.

Creating Efficient Meshes from Rhino® Surfaces

by James Truax, ThermoAnalytics, Inc. Version 1.0 I. Creating Surfaces From Curve Network – (NetworkSrf ® Surface – From Curve Network) Usage This is the newest surface creating command Rhino has implemented.  It is available in the latest beta version at www.rhino3d.com.  This command uses two series of curves to create a single surface.  These sets of curves run along and perpendicular to the surface.

Meshing With Rhino

> WATCH THE VIDEO Rhino is a NURBS modeler produced by Robert McNeel & Associates. A demo of Rhino can be downloaded from their website, http://rhino3d.com. Although Rhino has meshing capability, McNeel does not promote Rhino as a meshing utility. As a result, there is little information about meshing in the Rhino website, manual, or online help. In this document we will illustrate several techniques for creating a mesh using Rhino.

Schedule an Engineering Review of Your Project

To discuss your engineering requirements in detail, please use the contact form below or call our main office at (906) 482-9560 for a no-charge initial engineering review of your system.

Download Our Brochures Contact an Engineer